Unable to build new images

Incident Report for Beam

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 20:57 EDT

Identified

New image builds are getting stuck due to an issue with our object storage provider. Existing deployments are not affected.
Posted Jun 17, 2025 - 19:17 EDT
This incident affected: Platform.