Increased latency

Incident Report for Beam

Resolved

This incident has been resolved.
Posted Nov 21, 2024 - 16:26 EST

Investigating

We're experiencing a partial outage due to an external cloud provider. Still investigating the root cause.
Posted Nov 21, 2024 - 11:04 EST
This incident affected: Platform.