Increased Latency

Incident Report for Beam

Resolved

This incident has been resolved.
Posted Dec 10, 2024 - 15:29 EST

Identified

We are currently experiencing a storage issue with an upstream provider and you may notice increased latency. Working to resolve this ASAP.
Posted Dec 10, 2024 - 13:32 EST
This incident affected: API and Platform.